Baja Telecaster Electrics Problem

Need to know how to setup your guitar? How do you lower your action? How do you get rid of the Milli Vanilli stickers? Look here first.
Post Reply
Posts: 1
Joined: December 5th, 2017, 12:13 am

Baja Telecaster Electrics Problem

Post by TenderSurrender7 » December 5th, 2017, 12:28 am

Hi Folks!

I recently removed the stock pickup from my Baja Tele, and replaced them with Bareknuckle equivalents. 5 cables to unsolder (2 x earth, 2 x hot, 1 x neck pickup cover ground), and then an identical process to replace them.

The strange thing is that the guitar will play fine for anywhere around an hour or so before the neck pickup cuts out. Both of the neck pickup cables solder onto the S1 switch, and each time I resolder joint connected with the neck pickup (in case of a dry joint), it seems to remedy the guitar, only for it to eventually cut-out again.

Could it be something to do with the S-1 switch itself, or am I missing something obvious?

Thanks for your time - I really appreciate it!

Junior Member
Posts: 95
Joined: January 14th, 2017, 7:23 am

Re: Baja Telecaster Electrics Problem

Post by LessPaul » December 21st, 2017, 11:58 am

Dude sorry to ask more questions than provide answers, I fixed guitars for years, and that's just odd. I would start by checking the instrument cable and amp. So I would wait for it to fail, then try other cables, and guitars to see if the problem persists or gets resolved. For example, if you swap out guitars and the problem persists you know it's not the guitar. If you swap out the cable and the problem is resolved, you know it's the cable.

Is this consistently cutting out after an hour (ish) of use? Does it work again when you turn everything off and back on or does it need to cool off?

Hope this helps!

Post Reply