Tube Guitar amp Input Transformer Removal

Post your question here and an experienced guitar player or teacher will get back to you.
Post Reply
shena
newbie
Posts: 1
Joined: December 15th, 2017, 12:24 am

Tube Guitar amp Input Transformer Removal

Post by shena » December 15th, 2017, 12:40 am

Hi to all, newbie here ask for help, for a few weeks I've been trying to remove the input transformer from my little 60's Magnatone amp. The schematic indicates a 1:3 step up input transformer, but from reading elsewhere on the internet it seems that it is in fact a 1:1. Whenever the amp is run at the same time as other certain devices in my home e.g. laptop charger, washing machine, it picks up some severe hum (particularly with the washing machine). It sounds a bit like an arc welder. This makes the amp practically unplayable when these appliances are running. I'm certain this hum is being picked up by the input transformer.

Here is the schematic for the amp. The transformer in question is T2. http://www.magnatoneamps.com/schematics ... 01_412.pdf

I have tried bypassing the transformer, connecting a wire from the 10k resistor on the low gain input to the volume pot (and disconnecting from the transformer, which results in greatly increased hum (louder than the guitar) and reduced guitar volume. Connecting a jumper around the 220k resistor and .047 capacitor, to the volume pot ground lug results in a short which shuts off the house's circuit breaker. I cannot see why this occurs as there is no AC or DC http://www.kynix.com/Detail/669784/DC.html voltage between these.

Interestingly, I discovered the heater of the 20EZ7 is wired in reverse compared to the schematic (pin 2 connects to V2 heater, while pin 1 is used as the common return for nearby components e.g. V1 cathode, volume pot ground, 220k resistor and .047 capacitor. I'm not sure if this is relevant to the problem.

Any help here would be much appreciated. I'm completely stumped and out of ideas here. If you need any further information or clarification, just ask. I can also provide photos of the wiring if necessary I would like to think I'm not completely inept in the workings of tube amps, as I'm currently building a 5F6a Bassman.

Thankyou in advance

EDIT: My amp is run through an isolated 240-110v step down transformer, so the transformer is not needed for isolation. Also, I've added a 3 prong power cord and grounded the chassis

Further information: I replaced the 50uf filter caps a few weeks ago. Another thing, the hum reduces and cuts off when I turn off the volume pot, so the source of the hum must be before the volume pot.
Thanks all guys!

User avatar
Musicus
newbie
Posts: 32
Joined: November 22nd, 2017, 10:52 am
Location: Nashville TN

Re: Tube Guitar amp Input Transformer Removal

Post by Musicus » December 19th, 2017, 9:34 am

I don't understand putting in a 2/1 xformer in the power supply. That gives you either 240v or 60v, not 120v. So what are you doing, plugging the amp into a 240v outlet?

T2 is for safety (and for bridging the input Z), and must be there so you don't get zapped.

Either way, make sure your neutral ("grounded" conductor) rail integrity is intact through to your breaker panel and thoughout the house. Make sure your "grounding" system is up to date (code). btw the 220k resistor and .047uf cap. in series with the chassis and one side of the xformer T2 form a noise suppression ckt. Grounding the chassis disables it.
"Well, I hope the neighbors like THIS song!"

Post Reply