Skip to content
Tone Pots Not Worki...
 
Notifications
Clear all

Tone Pots Not Working on Squier Affinity Strat

7 Posts
5 Users
0 Likes
4,275 Views
 piov
(@piov)
New Member
Joined: 11 years ago
Posts: 2
Topic starter  

Hi guys I was hoping you could help me out with my electronics problem on my Squier Affinity Stratocaster.

I recently replaced the pickups and pickguard and since then my tone pots have had no effect. When it's plugged in and i dial the tone knobs with the correct pickups selected I hear a little bit of scratching but no real tone being rolled off. I read on a forum that maybe I shouldn't have contact of my tone pots to the shielding on the pickguard so i placed black electrical tape (seen in the pictures) but that didn't fix my problem. I took a couple pictures to try and illustrate my problem (please don't laugh at my poor soldering job). The two black wires running from the volume pot go to the trem claw and the ground on the input jack but I think the rest of the wiring is straight forward from the pictures. Hope you guys can help because I am a nursing student and I get very little time to sleep, let alone play my guitar, and I just want her to be in full working condition again so I can have my musical escape from all this rigid science!

Thanks in advance :)









   
Quote
(@ezraplaysezra)
Honorable Member
Joined: 12 years ago
Posts: 484
 

Sorry, If all your joints are good there is no reason this shouldn't work.


   
ReplyQuote
(@imalone)
Reputable Member
Joined: 14 years ago
Posts: 267
 

Shouldn't that capacitor go to earth somehow? It's soldered to the back of one tone pot, but that's not earthed (except potentially by the shielding before the electrical tape was added, but I wouldn't put my faith in that).


   
ReplyQuote
(@ezraplaysezra)
Honorable Member
Joined: 12 years ago
Posts: 484
 

bus the three pots together.


   
ReplyQuote
 piov
(@piov)
New Member
Joined: 11 years ago
Posts: 2
Topic starter  

Hey guys thanks for your responses - I was able to fix it using this diagram: I just had to wire the tone pots together and then connect one of them to the main ground :)


   
ReplyQuote
(@wosinek)
New Member
Joined: 11 years ago
Posts: 2
 

spot on...
I have fixed 2 Affinity Squier Strats with dead tone pot(s) by simply
soldering a ground wire across ALL THREE POTS.
Some Squiers tried to ground the pots via the threaded shaft nut
holding the pot body next to the thin shielding on the bottom
of the pickguard but that obviously goes bad over time.


   
ReplyQuote
(@mr-file)
Active Member
Joined: 11 years ago
Posts: 8
 

sthe tone pots are not grounded by the picture


   
ReplyQuote