Close
Skip to content

Forum

Marshall G100R CD a...
 
Notifications
Clear all

Marshall G100R CD amp blowing fuses


(@csmart01)
Trusted Member
Joined: 16 years ago
Posts: 70
Topic starter  

Hi. I got this amp and it worked great except the Effects pot was snapped off clean (couldn't even grab the shaft with pliers) so I decided to fix it :? So I ordered the pot from Marshall, took the head apart (easy as can be), de-soldered the old pot (I'm and engineer... but mechanical, not electrical) using a quality industrial soldering iron at work, installed the new pot no problem and re-assembled and voila! IT NO LONGER WORKS AT ALL :x I know on-line troubleshooting is near impossible but might anyone have any suggestions? I'm trying to get a schematic from Marshall but have not head back. The fuse is the correct size and type (slo-blow) but the moment you power up the power indicator illuminates and then the fuse blows and she shuts down. It's a solid state amp. Inside there is a metal box that has two RC jacks that go from the head into it that I was very careful to label (black and red) before unplugging and maybe I was so careful I labeled them backwards? I'm a little leary of just swapping them because if that's not the problem and I cross them maybe I'll do some real damage (The thing looks like a transformer or flourescent light ballast).

Any suggestions (aside from "stop playing amp technician" :D ) would be greatly appreciated.

Charlie


Quote
(@wes-inman)
Illustrious Member
Joined: 18 years ago
Posts: 5599
 

Charlie

First, we are neighbors. I am up in Torrington, maybe we can get together sometime.

I know very little about electronics myself, but if the amp worked and you simply replaced the broken pot properly with the correct pot and now the fuse blows, you must have reversed something. You could try just disconnecting those two RC jacks and firing it up. If the amp works and doesn't blow a fuse then it is likely you reversed those jacks somehow. It happens.

If you know something better than Rock and Roll, I'd like to hear it - Jerry Lee Lewis


ReplyQuote
(@ricochet)
Illustrious Member
Joined: 18 years ago
Posts: 7850
 

Yeah, the sequence of events points to an improper installation of the pot, or a defective pot. And if you overheated the pot on soldering that'd cause a problem, too. The resistance element is plastic.

"A cheerful heart is good medicine."


ReplyQuote
(@forrok_star)
Noble Member
Joined: 18 years ago
Posts: 2340
 

Is the box your asking about mounted to the bottom of the amp. It sounds like its the reverb unit. If there's a short in it, it can cause the amp troubles. However thats rare. Double check to see if anything plugged into the board is loose. You may also want to double check the pot you replaced to be sure you installed it the same and if it a match to the one removed. Check to see if maybe some solder dripped or is in a spot where it shouldn't be.

You might try this at night in the dark room. Remove the amp from the case or set it so you can see the inside of the amp. You need to becareful. Have the amp setting on the table with a replaced the fuse. Now turn the amp on and see if you notice anything other than the fuse blowing.

Here's a site with some Schematic's Marshall Schematic's

Joe


ReplyQuote
(@csmart01)
Trusted Member
Joined: 16 years ago
Posts: 70
Topic starter  

Thank you all! So here's what I found. There is a row of transistors that are bolted to a huge heat sink. In order to get the PC board out to solder in the new pot I had to take all that apart. During my last exploratory dive into that mess (scratching my head thinking what could have gone wrong) I noticed these thin clear plastic tabs tabs on the bottom of the cabinet and one stuck to the side of the heat sink. The transistors must be insulated from the heat sink. The little clear tabs go between the T and the sink before you screw them in. I did that and checked with a meter to verify they were isolated, put in a new fuse, plugged it in (still all apart... I am so sick of assembling and disassembling this thing) and hit power... :) :D So Wes... can you hear me now? :D Wait 'till my kid gets a hold of it... you will hear it. Nice seeing a fellow GN'er so close... PM me when your band plays local, we'll get out and see you guys.

Thanks to everyone else for the suggestions.

Charlie


ReplyQuote
(@forrok_star)
Noble Member
Joined: 18 years ago
Posts: 2340
 

Always good to hear when things work their way out and sound good.

Joe


ReplyQuote
(@wes-inman)
Illustrious Member
Joined: 18 years ago
Posts: 5599
 

Charlie

Glad you figured it out. By the way, I lived in Brookfield for about 1 year back in '75 right on Rte. 7. After that I moved to Pumpkin Hill Rd. in New Milford. So I know the area well. I will let you know if we get down your way, we have been hoping to get down to New Milford.

Wes

If you know something better than Rock and Roll, I'd like to hear it - Jerry Lee Lewis


ReplyQuote
(@the-dali)
Noble Member
Joined: 16 years ago
Posts: 1507
 

Wes - what is the name of your band? Do you play Central CT anywhere?

peace out.

-=- Steve

"If the moon were made of ribs, would you eat it?"


ReplyQuote
(@wes-inman)
Illustrious Member
Joined: 18 years ago
Posts: 5599
 

Dali Lima

My band's name is Twist of Fate. We have mostly played in the Northwest Corner and southern Mass., but we have gotten down to Naugatuck. Where are you?

If you know something better than Rock and Roll, I'd like to hear it - Jerry Lee Lewis


ReplyQuote
(@the-dali)
Noble Member
Joined: 16 years ago
Posts: 1507
 

Wes, no need to be so formal... you can call me "Dali" or just "Steve".

I'm in Colchester, but work in Hartford. I have some friends in Naugatuck. I'd go anywhere to see a good show. Thanks!

-=- Steve

"If the moon were made of ribs, would you eat it?"


ReplyQuote